Alkacon OCEE compatibility requirements

Alkacon OCEE is available for the following OpenCms versions:

  • OpenCms 11.x
  • OpenCms 10.x
  • OpenCms 9.x
  • OpenCms 8.x

Each supported version of OpenCms requires an exactly matching Alkacon OCEE version.

The newest version of Alkacon OCEE with the full functionality as described on this website is available for all official stable release versions of OpenCms 11.x.

Older OpenCms Versions like 10.x, 9.x and 8.x require a version of the Alkacon OCEE package compatible with that older OpenCms version. For these older OpenCms versions, the product description, as well as the functionality of the Alkacon OCEE package, can be different from the functionality described here.

Alkacon OCEE for OpenCms 11.x requires Java version 8 or newer. Older OCEE versions also support Java 7.

The following functionalities are Database dependent:

Currently the only supported databases for the Alkacon OCEE Replicator are:

  • MariaDB / MySQL DB (current versions*)
  • Oracle (current versions*)
  • PostgreSQL (current versions*)
  • MS SQL Server (current versions*)
  • DB2 (current versions*)

Other databases are not supported.

* ’Current versions’ means the last two current major stable release versions of the listed component. No alpha, beta or release candidate versions are supported. In case you are in doubt please ask us if the version you are using is supported.